Archive for the ‘Skype’ Category

Skype mit Abschaltungen zum 01.07.17

13.06.2017

Wie ich vor über 3 Monaten bereits berichtet habe, steht die neue Version 5.3.0.1 von Skype in den Startlöchern. Und wie befürchtet, wird es wieder brutale Abschaltungen geben. Die aktuell noch unter Linux laufende Version 4.3.0.37 wird dann nicht mehr laufen und es wird für die neue Software ein 64-Bit-Computer mit einem 64-Bit-Linux benötigt. Wenn die Ankündigung von Microsoft stimmt, wird auch Debian 7 nicht mehr unterstützt.

An alle meine Kontakte in Skype soll dies auch eine Info sein, dass ich möglicherweise ab dem 01.07.17 für länger oder für immer in Skype offline sein werde.

Siehe auch den Artikel bei zdnet.de Alte Versionen von Skype für Linux werden eingestellt


Advertisements

Das nächste Skype für Linux steht in den Startlöchern

02.03.2017

02.03.17 20:26

Nachdem ich nun mehrere Artikel zum Thema Skype für Linux gelesen habe und ich ja selber Skype seit Jahren nutze, bin ich der Sache ein wenig auf den Grund gegangen und habe die neuste Version bei skype.com einmal heruntergeladen.

skype-4-3-0-37-20170302 aktuell funktioniert Skype 4.3.0.37 noch, das man allerdings nicht mehr auf der Skype-Seite finden kann.

Während es in der Vergangenheit nur mit Tricks möglich war, das nur für 32-Bit-Systeme verfügbare Skype unter einem 64-Bit-Linux zu installieren, finden sich jetzt nur noch Versionen für 64-Bit-Systeme. Somit sind wohl alle 32-Bit-Computer zukünftig unter Linux von der Skype-Nutzung ausgeschlossen.

Sofort fällt mir auf, dass ich auf der Homepage keine Auswahl einer Linux Version angeboten bekomme (Ubuntu, Debian, Fedora, SuSE etc). Es wird auf meinem 32-Bit Laptop automatisch die skypeforlinux-64.deb heruntergeladen.

Im Ordner https://repo.skype.com/latest/ befinden sich aktuell (02.03.2017) nur 64-Bit Versionen:
skypeforlinux-64-alpha.deb 2017-03-01 09:16 48M
skypeforlinux-64-alpha.rpm 2017-03-01 09:16 64M
skypeforlinux-64.deb 2017-03-01 09:16 48M
skypeforlinux-64.rpm 2017-03-01 09:16 64M

In der Datei skypeforlinux-64.deb befinden sich Ordner, die auf den 28.03.2017 vordatiert sind. Ob das der Termin ist, an dem alle Nutzer der alten 32-Bit Versionen ausgesperrt werden sollen…? Es wäre nicht das erste Mal, dass Microsoft (der Eigentümer von Skype) Linux Nutzer auf diese Weise aussperrt. Ohne Ankündigung. Hauptsache weg.


Die Installation auf einem 64-Bit Computer mit Debian 8 liefert gleich Abhängigkeitsprobleme. Es wird gemeldet, dass gnome-keyring und apt-transport-https bei mir nicht installiert sind.

$ sudo dpkg --install skypeforlinux-64.deb

Alle Probleme werden beseitigt mit dem Befehl:

$ sudo apt-get -f install

skypeforlinux-64-deb-5-0-0-5 ein bewegter, tanzender Pinguin meldet u.a. die Versionsnummer

Die neue Oberfläche gefällt mir überhaupt nicht und ähnelt mehr einem Browser als einem Messenger. Mir fällt es immer wieder schwer zu erkennen, welcher Kontakt von mir nun eigentlich ausgewählt ist und wen ich da nun anschreibe, denn es geht kein separates Chat-Fenster für jeden einzelnen Kontakt auf. Die Menüs kommen mir unstrukturiert vor und ich habe das Gefühl, wieder viele Einstellungsmöglichkeiten verloren zu haben (ohne jedes Detail verglichen zu haben).

Textnachrichten zu verschicken ist möglich, aber ich konnte keine Audio- oder Videoverbindung herstellen.

Die Entwicklung von Skype ist zumindest für Linux enttäuschend. Ich werde sicher weitere Tests durchführen.


Nachtrag 02.03.17 22:00

Installationsversuch unter Debian 9 32-Bit

Die Pakete gnome-keyring und apt-transport-https waren bereits installiert. Wie erwartet, ist die Installation aber gescheitert:

$ sudo dpkg --install skypeforlinux-64.deb
dpkg: Fehler beim Bearbeiten des Archivs skypeforlinux-64.deb (--install):
Paket-Architektur (amd64) passt nicht zum System (i386)
Fehler traten auf beim Bearbeiten von:
skypeforlinux-64.deb


Skype unter Debian 9 mit Abhängigkeitsproblem

24.04.2016

Problem:

Skype steht für Debian nur in der recht alten Version 4.3.0.37 und eigentlich nur für Debian 7 zur Verfügung. Hinzu kommt, dass Skype nach wie vor nur als 32-Bit-Version angeboten wird. Das macht auf meinem 32-Bit Laptop sogar weniger Probleme als auf einem 64-Bit-Computer.

Der Installationsversuch gelingt aber auch unter Debian 9 testing.

$ sudo dpkg --install skype-debian_4.3.0.37-1_i386.deb

Der Paketmanager meldet allerdings ein Problem:

dpkg: Abhängigkeitsprobleme verhindern Konfiguration von skype:
skype hängt ab von libssl1.0.0; aber:
Paket libssl1.0.0 ist nicht installiert.

Nun können wir Skype starten und benutzen, aber der Paketmanager meldet ständig Fehler und wir können ohne eine Deinstallation von Skype keine weiteren Pakete installieren und keine Updates fahren.

Lösung:

Wir öffnen mit root-Rechten die Datei /var/lib/dpkg/status und lassen den Paketmanager diese Abhängigkeit „vergessen“.

$ sudo nano /var/lib/dpkg/status

var lib dpkg status skype

Mit Strg-W suchen wir nach Skype (ich mußte den Suchlauf 2x starten, weil der Begriff „Skype“ vorher bereits einmal auftritt)
in der Zeile „Depends:“ wandern wir mit den Cursortasten nach rechts und löschen „libssl1.0.0„.
Mit Strg-O speichern wir und mit Strg-X verlassen wir den Editor.

Auf die Idee gebracht hat mich der Artikel von linux-aha.de.


Skype als Zombie

05.10.2015

Wer das aktuelle Skype 4.3.0.37 unter Linux eine Zeit lang benutzt und dann schließt, muß damit rechnen, daß es sich nicht komplett beendet. Das Tool hängt häufig und belastet einen Prozessorkern zu 100% – bei meinem PC mit 2 Kernen sind es dann also 50% der Systemleistung.

Skype als Zombie

Um es zu beenden, kann man unter KDE Strg-Esc auslösen, oben Skype eintippen um die Liste zu filtern und dann den Prozess töten. Ein solcher Zombie mit Systemlast macht den Computer langsamer und erhöht zudem noch den Stromverbrauch, denn die Taktfrequenz wird bei modernen Computern in Abhängigkeit von der Last in einem solchen Fall ganz nach oben reguliert…


Skype-Ausfall

21.09.2015

Skype-Ausfall

„Der Internet-Telefoniedienst Skype ist heute von technischen Problemen weitgehend lahmgelegt worden…“
>>> hier weiterlesen <<<


14:00 Mein Skype-Messenger will sich gar nicht mit dem Server verbinden und läßt das graue Symbol ständig rotieren. Es scheint ein Totalausfall zu sein.


14:25 Skype meldet via Twitter, dass nichts geht…

We are aware of an issue affecting Skype status at the moment, and are working on a quick fix

Vielleicht ist auch nur die Festplatte bei der NSA voll ;-)


19:00 Skype hat sich gerade vor meinen Augen eingeloggt! :-)
Auch wenn es zwischendurch immer wieder mal die Verbindung verliert, kann man doch zumindest wieder Textnachrichten versenden.


Skype-Klänge setzen den VLC auf Pause

15.05.2015

Problem:

Während ein Video oder eine Audio-Datei mit dem VLC abgespielt wird, gibt Skype ein Geräusch aus (z.B. wenn mich jemand anschreibt oder anruft oder den Testklang). Diese Aktion setzt den VLC-Player auf Pause. Audacious ist nicht betroffen.

Lösung:

Dies ist kein Bug, sondern ein Feature. Pulseaudio kann man so konfigurieren, dass es sich so verhält oder auch nicht. Abschalten läßt sich diese Pausenschaltung, indem man die Datei /etc/pulse/default.pa mit root-Rechten öffnet, z.B. mit
$ kdesudo kate /etc/pulse/default.pa

und darin die Zeile „load-module module-role-cork“ sucht und mit einem # davor auskommentiert.

Jetzt sollte man entweder den Computer neu starten oder Skype, VLC etc. beenden und pulseaudio neu starten.

pulseaudio beenden:
$ pulseaudio -k

pulseaudio als Dämon staten:
$ pulseaudio -D

Die Lösung ist in dieser Diskussion hier zu finden.


Skype startet nicht mehr unter Debian 8

19.09.2014

Problem:

Skype startet nicht mehr

$ skype %U
skype: error while loading shared libraries: libGL.so.1: cannot open shared object file: No such file or directory

Das Paket ia32-libs-gtk ist nicht mehr in den Quellen vorhanden und wurde wohl bei einem Update deinstalliert oder verschoben. (Skype ist kein 64-Bit-Tool, sondern nur 32-Bit.)

Lösung: (Nachtrag 19.09.14)

Herausfinden wo sich die libGL.so.1 befindet mit:

$ find /usr/ -iname "libGL.so.1"
/usr/lib/x86_64-linux-gnu/nvidia/legacy-304xx/libGL.so.1
/usr/lib/x86_64-linux-gnu/nvidia/current/libGL.so.1
/usr/lib/x86_64-linux-gnu/nvidia/libGL.so.1
/usr/lib/x86_64-linux-gnu/libGL.so.1
/usr/lib/mesa-diverted/x86_64-linux-gnu/libGL.so.1
/usr/lib/mesa-diverted/i386-linux-gnu/libGL.so.1
find: "/usr/share/mumble-django": Keine Berechtigung

Skype starten mit

$ LD_PRELOAD=/usr/lib/mesa-diverted/i386-linux-gnu/libGL.so.1 skype &


Nachtrag 28.07.15

Dieses Problem ist nur auf 64-Bit-Systemen vorhanden.


Skype läuft nicht mehr

11.08.2014

Seit kurz nach Mitternacht funktioniert Skype nicht mehr unter Debian. Das Tool versucht sich nicht mehr einzuloggen und behandelt meine Login-Daten als wären sie ungültig.

Als früher einmal die Server nicht ordentlich liefen, wurde dies im Clienten mit drehenden Pfeilen angezeigt und der Login so lange versucht bis es wieder ging.

Nun meldet heise „Keine Unterstützung mehr für Mac OS X 10.5.8 und älter“ und Chip „Skype für ältere Systeme gesperrt“ zitiert Microsoft „Ein Update wird es nicht geben: Wer Windows Phone 7 nutzt, kann nicht auf die nächste Version Windows Phone 8 updaten, so Microsoft.“

Wie ich gehört habe, sollen Windows-Nutzer zu einem Update gezwungen worden sein und in der neuen Version dann mit Werbung belästigt werden.

Auf der Homepage von Skype findet man nur einen allgemeinen Hinweis „Probleme beim Anmelden bei Ihrer Skype App? Sie müssen möglicherweise Ihre Skype-Version aktualisieren.“

skype.de

Skype 2.2 beta unter Debian 7 (die bis letzte Nacht lief)

skype2.2beta unter Debian7--

Skype 4.2 unter Debian 8 (die bislang ebenfalls lief)

skype4.2 unter Debian8-

Skype für Debian 8 wird noch immer nicht angeboten

Skype für Debian8 wird nicht angeboten-

Also lade ich die aktuell verfügbare skype-debian_4.3.0.37-1_i386.deb herunter und installiere sie.

Skype4.3 unter Debian8 login1

Skype4.3 unter Debian8 login2-

Skype4.3 unter Debian8 login3-

Danach schließt sich das Fenster ohne Fehlermeldung, das Programm ist beendet.

Von der Konsole aus gestartet ist die Fehlermeldung die folgende:

$ skype %U
Abgebrochen

Microsoft hat es scheinbar voll im Griff – das Tool wird immer unbenutzbarer. :-(
Ich werde mich nach einer Alternative umschauen (müssen).


Nachtrag 11.08.14 11:30

Eine Installation von skype-debian_4.3.0.37-1_i386.deb hat unter Debian 7 zunächst nicht funktioniert und folgende Fehlermeldung ergeben:

$ sudo dpkg --install skype-debian_4.3.0.37-1_i386.deb

Vorbereitung zum Ersetzen von skype 2.2.0.35-1 (durch .../skype-debian_4.3.0.37-1_i386.deb) ...
Ersatz für skype wird entpackt ...
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von skype:
skype hängt ab von libqtwebkit4 (>= 2.1.0~2011week13).
skype hängt ab von libasound2-plugins.

dpkg: Fehler beim Bearbeiten von skype (--install):
Abhängigkeitsprobleme - verbleibt unkonfiguriert
Trigger für gnome-menus werden verarbeitet ...
Trigger für desktop-file-utils werden verarbeitet ...
Trigger für hicolor-icon-theme werden verarbeitet ...
Fehler traten auf beim Bearbeiten von:
skype

Dies konnte mit

# apt-get -f install

und

$ sudo apt-get update && sudo apt-get dist-upgrade && sudo apt-get autoclean && sudo apt-get autoremove

zwar behoben werden, aber das Programm lädt, um genau so wie unter Debian 8 nach Eingabe von Benutzernamen und Paßwort abzubrechen.

Bin dann erstmal offline…


Nachtrag 11.08.14 12:15

wiki.ubuntuusers.de bringt den Hinweis:
„Ende Juli 2014 wurde der Skype-Service offenbar modifiziert, so dass man sich mit alten Skype-Versionen nicht mehr anmelden kann. Der Support für alle Skype-Versionen vor 4.3 (Linux) ist eingestellt worden, so dass Skype 4.3 installiert sein muss. Diese Version läuft allerdings nur mit PulseAudio. Bitte updaten.“

Nun habe ich unter Debian 7 kein pulseaudio installiert und somit die aktuellste Version von skype-ubuntu-precise_4.3.0.37-1_i386.deb heruntergeladen und unter Ubuntu 12.04 installiert mit

$ sudo dpkg --install skype-ubuntu-precise_4.3.0.37-1_i386.deb

doch beim starten erscheint

$ skype
Abgebrochen (Speicherabzug geschrieben)

Es ist also noch schlimmer als unter Debian – das Tool startet überhaupt nicht.

Skype kann man wieder deinstallieren mit:

$ sudo dpkg -r skype

Für mich ist Skype jetzt erst einmal Geschichte. Wenn Microsoft ihr proprietäres Programm nicht in Ordnung bringt, ist das Tool nicht mehr unter Linux nutzbar. Zusammen mit den ausgesperrten Apple-Nutzern und den ausgesperrten Windows Phone 7 Nutzern ist das ein guter Anfang, diese überflüssige Software endgültig vom Computer zu entfernen.


Nachtrag 11.08.14 13:00

Am 05.08.14 hat pro-linux.de gmeldet „Wie das Unternehmen nun bekannt gab, unterstützt der Dienst ab sofort nur noch Client-Versionen ab der Version 4.3. Unter dem freien Betriebssystem bedeutet dies, dass ab sofort nur noch die neueste Version der Anwendung eingesetzt werden kann … Anwender, die den Versuch unternehmen, sich mit einer alten Version in Skype anzumelden, erhalten seit dem Wochenende eine Fehlermeldung, dass entweder die Serververbindung unterbrochen oder die Login-Daten inkorrekt seien … Mit der neuen Version … setzt (Skype) vollständig auf PulseAudio … Alle Anwender, die die Sound-Middleware nicht einsetzen, können dementsprechend nicht mehr die Anwendung nutzen. Zudem kommt noch, dass die neueste Version bei Anwendern häufig abstürzt, während die alte noch tadellos funktionierte.“


Nachtrag 11.08.14 13:45 – Lösung für Debian 7

Skype beenden (falls es überhaupt gestartet ist ;-) und den unsichtbaren Profilordner umbenennen, z.B. mit

$ mv ~/.Skype ~/.Skype.bak

Danke an dasuxullebt für Deine Rückmeldung! Du hast mich nochmal motiviert, weiter zu suchen und diese Lösung zu finden.

Nachtrag 11.08.14 16:45

Die Lösung für Debian 7 hilft auch unter Debian 8.

Durch das Verschieben des alten Profils sind allerdings die alten Chats nicht mehr abrufbar. Mal sehen, ob ich das noch lösen kann…


Debian 8: Skype installieren

24.02.2014

Als Distribution wählen wir auf www.skype.com/de „Debian 7.0 (multiarch)“ und laden (aktuell) die Datei skype-debian_4.2.0.13-1_i386.deb herunter.

Um meine Anleitung im folgenden 1:1 nutzen zu können, sollte man sudo aktivieren.

Wir fügen die i386 Architektur in unserem System hinzu (offensichtlich ist Skype nicht für 64-Bit-Systeme kompiliert):
$ sudo dpkg --add-architecture i386

Solange das System im Status „testing“ ist, sollte man regelmäßig Updates fahren, aber besonders vor einer Installation:
$ sudo apt-get update && sudo apt-get dist-upgrade && sudo apt-get autoclean && sudo apt-get autoremove

nun installieren wir Skype
$ sudo dpkg --install skype-debian_4.2.0.13-1_i386.deb

sollten Abhängigkeitsprobleme (z.B. von libc6 und vielen anderen) angezeigt werden, kann man das klären lassen mit
$ sudo apt-get -f install
und anschließend die Installation wiederholen