Posts Tagged ‘Debian 8 Jessie’

Skype mit Abschaltungen zum 01.07.17

13.06.2017

Wie ich vor über 3 Monaten bereits berichtet habe, steht die neue Version 5.3.0.1 von Skype in den Startlöchern. Und wie befürchtet, wird es wieder brutale Abschaltungen geben. Die aktuell noch unter Linux laufende Version 4.3.0.37 wird dann nicht mehr laufen und es wird für die neue Software ein 64-Bit-Computer mit einem 64-Bit-Linux benötigt. Wenn die Ankündigung von Microsoft stimmt, wird auch Debian 7 nicht mehr unterstützt.

An alle meine Kontakte in Skype soll dies auch eine Info sein, dass ich möglicherweise ab dem 01.07.17 für länger oder für immer in Skype offline sein werde.

Siehe auch den Artikel bei zdnet.de Alte Versionen von Skype für Linux werden eingestellt


Debian 8 Jessie Update auf 8.8

07.05.2017

14.03.17 12:00 Version 8.8 ist in Arbeit

Ein Update von Debian 8 Jessie (stable) auf 8.8 ist vermutlich für April oder Anfang Mai geplant.

Siehe Diskussion 8.8 planning


11.04.17 22:36 Ankündigung

Ein Update von Debian 8 Jessie (stable) auf 8.8 ist für Samstag, den 06.05.17 geplant.

Diese Info kann man in den Mailinglisten finden:
Upcoming stable point release (8.8)
„The next point release for „jessie“ (8.8) is scheduled for Saturday, May 6th. Processing of new uploads into jessie-proposed-updates will be frozen during the preceding weekend.“


01.05.17 23:22 Details zum Update

[SUA 119-1] Upcoming Debian 8 Update (8.8)


06.05.17 14:58 Das angekündigte Update ist bald verfügbar

06.05.17 14:58 Adam D. Barratt

The archive side of the point release has now finished. The next scheduled archive update is in around an hour from now, so packages should start appearing on mirrors in a few hours‘ time.


06.05.17 17:45 Offizielle Nachricht

Debian 8 aktualisiert: 8.8 veröffentlicht


06.05.17 23:00 Ein paar inoffizielle Hilfen von mir

Die aktuell installierte Version kann man abfragen mit dem Befehl:
$ cat /etc/debian_version
8.7

Ein Update ist in jedem Fall empfehlenswert, da hiermit viele Sicherheitsupdates eingespielt werden. Weil Debian Jessie im Status „stable“ ist, sollten keine Schwierigkeiten zu erwarten sein.

einlesen der Quellen mit
# apt-get update

installieren der Updates mit
# apt-get dist-upgrade

und optional noch die Platte säubern mit
# apt-get autoclean
# apt-get autoremove

$ cat /etc/debian_version
8.8

Wer sudo aktiviert hat, kann auch im Ubuntu-Stil alle Befehle in einer Zeile starten:
$ lsb_release -a && sudo apt-get update && sudo apt-get dist-upgrade && sudo apt-get autoclean && sudo apt-get autoremove && lsb_release -a

Distributor ID: Debian
Description: Debian GNU/Linux 8.8 (jessie)
Release: 8.8
Codename: jessie

Da ich aktuell mit Debian 9 arbeite, habe ich das Update noch nicht ausprobiert. Ich werde den Artikel ergänzen, wenn ich meine Installationen von Debian 8 aktualisiert habe.


07.05.17 12:00 Nachtrag

Das Update lief bei mir auf einem 32-Bit-System fehlerfrei durch, nachdem ich die Aktualisierung 2x anstoßen mußte. Beim ersten Mal wurde nur ein Teil der Änderungen gefunden.


Wieder auf den Dekstop umgezogen

26.03.2017

Weil mein T60 leider ein paar scheußliche Macken an den Tag gelegt hat (immer wieder endlose Tastenwiederholungen von Geisterhand bis man eine Taste drückt), bin ich wieder auf meinen Desktop umgezogen. Der PC fühlt sich wesentlich schneller an und macht mehr Spaß. Hoffentlich habe ich nicht wieder irgendwelche Effekte, die mich auf eine andere Hardware treiben. Ich möchte schließlich ein paar Schritte vorwärts gehen und auf dem Computer die 4 TB Platte umformatieren und neue Systeme wie Debian 9 ausprobieren und hier berichten anstatt mit ekligen Zickereien der Hardware zu kämpfen. Ich war fast auf den Tag genau 11 Monate auf dem T60 unterwegs und ab jetzt arbeite ich wieder mit dem GigaByte-GA-G41M-Combo Board. Ich musste schmerzhaft lernen wie wichtig so ein Board ist. Mein Elitegroup-Board ist ja vor ein paar Jahren mit vielen Effekten unbenutzbar geworden und nun scheint der T60 zumindest auch eine Macke zu haben, die vermutlich auch mit seinem Board zu tun hat. Hoffentlich hat GigaByte eine bessere Qualität. Immerhin haben die ihre angeblich besonders guten Kondensatoren gelobt.

Der Umzug dauerte diesmal unter eine Stunde. Der Trick war, dass ich die 2,5″ 1 TB Festplatte aus dem Laptop ausgebaut habe und in den Desktop-PC eingebaut habe. Blöd, dass ich jetzt nur ein 32-Bit-System auf einem 64-Bit-Rechner am laufen habe – das bremst das System ein wenig. Aber super, dass ich nichts ändern musste, außer KDE mit meiner „neuen“ Netzwerkkarte bekannt zu machen.

Der Umzug bestand also diesmal aus einem Hardwareumzug der Festplatte. Den mechanischen Adapter hierzu habe ich über Amazon bestellt. Die genaue Bezeichnung lautet „Einbaurahmen für 2,5″ Festplatten / SSD’s auf 3,5″ Adapter Wechselrahmen Mounting Frame Halterung Schienen inkl. Schrauben“, der Preis lag am Donnerstag bei 5,99 EUR incl. Versand über den Händler Sascha Becker. Ich habe am Donnerstag um 20:00 bestellt, am Freitag um ca. 08:00 eine Versandbestätigung per eMail erhalten und die Ware war am Samstag Vormittag im gepolsterten Umschlag im Briefkasten. Das geht nicht besser.

Das Blech paßt super, ist stabil, aber die Farbe geht schnell ab und die Kanten sind tatsächlich – wie in Rezensionen bei Amazon beschrieben – ein wenig scharf. Über diese Dinge kann man hinwegsehen, denn man baut ja nicht täglich die Platte aus und ein.

Was ich nicht gut finde sind 4 der 8 mitgelieferten Schrauben. Die Lösung mit den Plastik-Unterlegscheiben scheint mir eine Entschuldigung des Herstellers zu sein unter dem Motto „wir hatten leider keine passenden Schrauben“. Tatsächlich passen die Schauben nicht vollständig ins Gewinde der Festplatte, was auch durch die Unterlegscheiben nicht besser wird. Somit läßt sich die Platte mit den gegebenen Schrauben nicht ordentlich ans Blech montieren.

Ich hatte aber noch alte Computer-Schauben, die genau passen. Wer noch aus alten Computer-Gehäusen Schauben zur Befestigung der Slotbleche hinten hat, sollte die mal probieren. Bei mir ging’s damit.

Ich bin sehr froh, meine 1 TB Platte in den Desktop-Computer eingebaut zu haben. Nun ist der Computer noch leiser und noch verbrauchsärmer. Und die 2,5″ 1 TB Platten kosten ja nur noch ca. 55 EUR. Also eine echte Alternative zu den herkömmlichen 3,5″ Platten und auch zu den teuren SSDs mit viel zu wenig Speicher, die ja auch noch sehr spontan sterben, sodass man niemals ohne Datenverlust über den Tod einer SSD hinwegkommt. Ich denke, ich habe jetzt einen guten Mittelweg gefunden.


Das nächste Skype für Linux steht in den Startlöchern

02.03.2017

02.03.17 20:26

Nachdem ich nun mehrere Artikel zum Thema Skype für Linux gelesen habe und ich ja selber Skype seit Jahren nutze, bin ich der Sache ein wenig auf den Grund gegangen und habe die neuste Version bei skype.com einmal heruntergeladen.

skype-4-3-0-37-20170302 aktuell funktioniert Skype 4.3.0.37 noch, das man allerdings nicht mehr auf der Skype-Seite finden kann.

Während es in der Vergangenheit nur mit Tricks möglich war, das nur für 32-Bit-Systeme verfügbare Skype unter einem 64-Bit-Linux zu installieren, finden sich jetzt nur noch Versionen für 64-Bit-Systeme. Somit sind wohl alle 32-Bit-Computer zukünftig unter Linux von der Skype-Nutzung ausgeschlossen.

Sofort fällt mir auf, dass ich auf der Homepage keine Auswahl einer Linux Version angeboten bekomme (Ubuntu, Debian, Fedora, SuSE etc). Es wird auf meinem 32-Bit Laptop automatisch die skypeforlinux-64.deb heruntergeladen.

Im Ordner https://repo.skype.com/latest/ befinden sich aktuell (02.03.2017) nur 64-Bit Versionen:
skypeforlinux-64-alpha.deb 2017-03-01 09:16 48M
skypeforlinux-64-alpha.rpm 2017-03-01 09:16 64M
skypeforlinux-64.deb 2017-03-01 09:16 48M
skypeforlinux-64.rpm 2017-03-01 09:16 64M

In der Datei skypeforlinux-64.deb befinden sich Ordner, die auf den 28.03.2017 vordatiert sind. Ob das der Termin ist, an dem alle Nutzer der alten 32-Bit Versionen ausgesperrt werden sollen…? Es wäre nicht das erste Mal, dass Microsoft (der Eigentümer von Skype) Linux Nutzer auf diese Weise aussperrt. Ohne Ankündigung. Hauptsache weg.


Die Installation auf einem 64-Bit Computer mit Debian 8 liefert gleich Abhängigkeitsprobleme. Es wird gemeldet, dass gnome-keyring und apt-transport-https bei mir nicht installiert sind.

$ sudo dpkg --install skypeforlinux-64.deb

Alle Probleme werden beseitigt mit dem Befehl:

$ sudo apt-get -f install

skypeforlinux-64-deb-5-0-0-5 ein bewegter, tanzender Pinguin meldet u.a. die Versionsnummer

Die neue Oberfläche gefällt mir überhaupt nicht und ähnelt mehr einem Browser als einem Messenger. Mir fällt es immer wieder schwer zu erkennen, welcher Kontakt von mir nun eigentlich ausgewählt ist und wen ich da nun anschreibe, denn es geht kein separates Chat-Fenster für jeden einzelnen Kontakt auf. Die Menüs kommen mir unstrukturiert vor und ich habe das Gefühl, wieder viele Einstellungsmöglichkeiten verloren zu haben (ohne jedes Detail verglichen zu haben).

Textnachrichten zu verschicken ist möglich, aber ich konnte keine Audio- oder Videoverbindung herstellen.

Die Entwicklung von Skype ist zumindest für Linux enttäuschend. Ich werde sicher weitere Tests durchführen.


Nachtrag 02.03.17 22:00

Installationsversuch unter Debian 9 32-Bit

Die Pakete gnome-keyring und apt-transport-https waren bereits installiert. Wie erwartet, ist die Installation aber gescheitert:

$ sudo dpkg --install skypeforlinux-64.deb
dpkg: Fehler beim Bearbeiten des Archivs skypeforlinux-64.deb (--install):
Paket-Architektur (amd64) passt nicht zum System (i386)
Fehler traten auf beim Bearbeiten von:
skypeforlinux-64.deb


Firefox-Kurzinfos unlesbar

08.02.2017

Problem:

Die „tooltip messages“, also die aufpoppenden Kurzinfos des Firefox 51.0.1 werden plötzlich in dunkler Schrift auf dunklem Grund angezeigt und sind somit unlesbar. Leider ist das unabhängig von den installierten Add-ons und tritt sogar beim online-Banking auf. (Meine Bank zeigt nur noch Symbole an und die Kurzinfos sind unlesbar, sodass man im Dunklen herumstochert.)

tooltip-messages-ff51-0-1-debian8-kde4-14-2

Das Problem tritt übrigens nicht auf, wenn man einen Windows-Firefox unter wine laufen läßt. Das kann man im Notfall schon als Workaround durchgehen lassen, ist aber keine Lösung.

tooltip-messages-ff51-0-1-win-wine-debian8-kde4-14-2

Lösung:

KDE > Rechner > Systemeinstellungen > Erscheinungsbild von Anwendungen > Farben > „Zion“ auswählen > Anwenden.

tooltip-messages-ff51-0-1-debian8-kde4-14-2-loesung

Auch wenn es nicht mein Lieblings-Farbschema ist, so sind damit doch alle Texte wieder lesbar.

tooltip-messages-ff51-0-1-debian8-kde4-14-2-loesung-andere-farbeinstellungen


Nachtrag = bessere Lösung:

Anstatt ein anderes Farbschema auszuwählen, kann man das aktuelle Schema verändern:

KDE > Rechner > Systemeinstellungen > Erscheinungsbild von Anwendungen > Farben > Farbauswahl > „Kurzinfo-Hintergrund“ > von schwarz auf weiß stellen > OK > Anwenden

tooltip-messages-ff51-0-1-debian8-kde4-14-2-loesung-andere-farbeinstellungen2

10.02.17 noch ein Nachtrag

Bei der Farbauswahl sollte man vielleicht ein mittleres Grau wählen. Ich habe festgestellt, dass Libreoffice ansonsten weiß auf weiß schreibt.


Debian 8 Jessie Update auf 8.7

14.01.2017

21.12.16 19:33 Version 8.7 ist in Arbeit

Ein Update von Debian 8 Jessie (stable) auf 8.7 ist vermutlich für Samstag, den 14.01.17 geplant.

Siehe Diskussion 8.7 planning


27.12.16 22:11 Ankündigung

Ein Update von Debian 8 Jessie (stable) auf 8.7 ist für Samstag, den 14.01.17 geplant.

Diese Info kann man in den Mailinglisten finden:
Upcoming stable point release (8.7)
„The next point release for „jessie“ (8.7) is scheduled for Saturday, January 14th. Processing of new uploads into jessie-proposed-updates will be frozen during the preceding weekend.“


09.01.17 23:27 Details zum Update

[SUA 114-1] Upcoming Debian 8 Update (8.7)


14.01.17 13:23 Das angekündigte Update ist bald verfügbar

14.01.17 13:23 Adam D. Barratt

The archive side of the point release has now finished. The next scheduled archive update is in around an hour and a half from now, so packages should start appearing on mirrors in a few hours‘ time.


14.01.17 18:15 Das angekündigte Update ist verfügbar

Ein paar inoffizielle Hilfen von mir:

Die aktuell installierte Version kann man abfragen mit dem Befehl:
$ cat /etc/debian_version
8.6

Ein Update ist in jedem Fall empfehlenswert, weil viele Sicherheitsupdates eingespielt werden. Da Jessie im Status „stable“ ist, sollten keine Schwierigkeiten zu erwarten sein.

neues einlesen der Quellen mit
# apt-get update

installieren der Updates mit
# apt-get dist-upgrade

und optional noch die Platte säubern mit
# apt-get autoclean
# apt-get autoremove

$ cat /etc/debian_version
8.7

Wer sudo aktiviert hat, kann auch im Ubuntu-Stil alle Befehle in einer Zeile starten:
$ lsb_release -a && sudo apt-get update && sudo apt-get dist-upgrade && sudo apt-get autoclean && sudo apt-get autoremove && lsb_release -a

Distributor ID: Debian
Description: Debian GNU/Linux 8.7 (jessie)
Release: 8.7
Codename: jessie

Das Update lief bei mir fehlerfrei durch.


14.01.17 20:46 Offizielle Nachricht

Debian 8 aktualisiert: 8.7 veröffentlicht


Netzwerkverbindung kommt nicht zustande

06.01.2017

Problem:

Nach einer Neuinstallation von Debian 8 mit KDE als Oberfläche, kommt keine Netzwerkverbindung zustande. Wenn man in der Kontroll-Leiste auf das Symbol für die Netzwerkverbindung klickt, findet man die Meldung „Netzwerkadresse wird bezogen“.

debian8-kde-netzwerkadresse-wird-bezogen

Erst wenn man „Verbindung trennen“ klickt (der Knopf erscheint erst wenn man die Maus über den Eintrag der Verbinung hält) und anschließend wieder „Verbinden“ klickt, bekommt der Computer eine IP und kann ins Netz.

Lösung:

Wir öffenen die Datei /etc/network/interfaces mit root-Rechten:
$ sudo nano /etc/network/interfaces

und fügen die folgenden 2 Zeilen hinzu:

allow-hotplug eth0
iface eth0 inet dhcp

Nach einem Reboot sollte das Problem verschwunden sein.

Und nun das traurige an dieser Lösung:
In meinem Artikel WLAN-Abbrüche habe ich vor einiger Zeit Probleme mit dem WLAN gelöst, indem ich genau diese 2 Zeilen auskommentiert habe. – Wer also eine bessere Lösung für mein Problem kennt, darf gerne kommentieren.


glxinfo: „couldn’t find RGB GLX visual or fbconfig“

30.12.2016

Problem:

Die 3D-Beschleunigung funktioniert trotz der Installation nach der Mesa-Anleitung nicht. OpenGL (KDE > Systemeinstellungen > Arbeitsflächen-Effekte > Erweitert > Composit-Typ: OpenGL 2.0 UND Qt-Grafiksystem: Raster) funktioniert nicht.

$ glxgears -info
sollte 3 sich drehende Zahnräder zeigen, aber auch das funktioniert nicht

$ glxinfo | grep rendering
liefert den Fehler „couldn’t find RGB GLX visual or fbconfig“

Lösung:

Aus der Sitzung abmelden und mit Strg-Alt-F1 eine Konsole öffnen. Dort den xserver entfernen, neu installieren und booten:

$ sudo apt-get remove xserver-xorg xserver-xorg-video-intel && sudo apt-get install xserver-xorg xserver-xorg-video-intel && sudo dpkg-reconfigure xserver-xorg && sudo reboot

Zum Hintergrund:

Ich habe vor einiger Zeit mein altes, defektes Mainboard durch das neue „GigaByte GA-G41M-Combo“ ausgetauscht. Ich habe also RAM, CPU, Festplatte etc. an das neue Board gehängt. Die onboard-Grafik habe ich nie benutzt, weil der nvidia-Treiber noch installiert war. Dieser Treiber hat verhindert, dass KDE oder Gnome ohne die nvidia-Karte starten konnte. Xfce konnte man starten. Also habe ich einfach meine alte nvidia-Grafikkarte weiter eingesetzt.

Nun habe ich ein wenig Zeit investiert und die Karte ausgebaut, um einmal die onboard-Grafik zum laufen zu bringen und um zu sehen, ob die Grafik-Leistung für meine Zwecke ausreichend ist. Man muß tatsächlich sämtliche Pakete deinstallieren, die ein nvidia im Namen tragen. Danach konnte ich KDE Starten. Aber die 3D-Beschleuningung wollte noch immer nicht funktionieren. Mit obiger Lösung ging es dann aber doch, die Zahnräder drehen sich und der KDE-Würfel (Animation des Arbeitsflächenwechsels) funktioniert ebenfalls. Die Bewegungen sind sehr flüssig und ich werde die neue Hardware-Kombination wohl demnächst für länger ausprobieren.

Die nvidia-Grafikkarte habe ich deshalb schon länger loswerden wollen, weil sie 1. immer mal wieder Probleme in der Darstellung macht (egal ob mit dem proprietären nvidia-Treiber oder mit nouveau) 2. sehr stark heizt und somit 3. das Netzteil belastet 4. sinnlos Strom „verbraucht“ 5. den Netzteil-Lüfter schneller und somit lauter laufen läßt und 6. mit der Hitze benachbarte Bauteile (Kondensatoren) schneller altern läßt. Die ersten Tests mit der onboard-Grafik zeigen mir, dass die Entscheidung „raus mit dem Ding“ gar nicht so schlecht war. Der Umzug vom Laptop zurück auf den „richtigen“ Computer steht wohl bald an. :-)


Lange nichts gehört vom Acer Aspire Revo R3610 Nettop

27.11.2016

In den letzten Tagen ist viel geschehen. Eigentlich passiert bei mir immer viel, wenn ich hier wenig schreibe. Mein Wohnzimmer-Fernseher ist nach nur 9 Jahren sehr plötzlich und völlig unerwartet verstorben. Ein neuer steht bereits am Platz. Über den neuen werde ich wohl demnächst eine Rezension veröffentlichen, um dem einen oder anderen die Kaufentscheidung zu erleichtern und auch um mich selber später mal zu erinnern.

Nun hatte ich hinter den alten Fernseher den Nettop montiert, um dort auch mal Videos oder Fotos zeigen zu können. Der neue Fernseher hat diese Funktionen bereits integriert und spielt z.B. mp4-Dateien vom Stick ab. Also habe ich den Nettop nicht wieder an den Fernseher montiert.

Aber was nun mit dem Computer tun? Ich hatte dort noch Debian 6 drauf installiert und Debian 7. Das Debian 6 wird ja nun seit einiger Zeit gar nicht mehr unterstützt und somit habe ich versucht, das per Upgrade auf 7 und dann auf 8, also stable, zu bekommen. Viele viele Stunden sind damit vergangen und letztlich habe ich bemerkt, dass Videos nicht mehr liefen. Es wurde ein Standbild angezeigt und das war’s. Ich habe diese Installation von 2010 (es war der Schnee-Monat Dezember 2010, den ich nicht vergessen kann) bereits aufgegeben und letztlich noch versucht, das System nach der Anleitung auf 64-Bit zu bringen. 2010 bin ich gar nicht auf die Idee gekommen, dass der PC 64-Bit beherrschen könnte und so hatte ich nur 32-Bit installiert.

Wie dem auch sei, ist diese Veränderung komplett in die Hose gegangen und irgendwann lief dann gar nichts mehr und ich habe mit diesem Image und mit dieser Anleitung einen Boot-Stick erstellt (sudo cp debian.iso /dev/sdX und sudo sync) und installiert. Das ging dann innerhalb von ca. 1,5 Stunden und nun laufen auch wieder Videos auf der Maschine. Und das sogar ohne den proprietären nvidia-Treiber, sondern mit dem mitgelieferten freien nouveau. Lief wirklich nicht schlecht.

Was noch beim Nettop fehlt ist eine neue Knopfzelle für den BIOS-Speicher. Ich werde also noch das Gehäuse auseinander nehmen müssen.

Ich überlege nun wie ich weiter machen werde. Mein Laptop T60 stört mich eigentlich nur. Ich benötige eigentlich gar keinen Laptop und habe den nur im Einsatz, weil der leiser ist und weniger Strom zieht. Der Akku ist eh dahin, aber ich habe auch nicht vor, mit dem Gerät durch die Wohnung zu laufen. Die Linux-Treiber laufen super auf dem T60. Aber ich habe das Problem, dass immer mal wieder Tastatureingaben endlos (von Geisterhand) wiederholt werden bis ich eine Taste drücke. Die Tastatur trägt keine Schuld. Möglicherweise hat der Laptop bereits einen leichten Hardware-Defekt.

Hinzu kommt, dass der zugeklappte Laptop auf der Dockingstation eine Menge Platz verschwendet. Der Nettop steht hingegen ziemlich unauffällig rum. Die Geräuschkulisse ist beim Nettop ein wenig größer als beim Laptop, aber das ist alles erträglich. Den Stromverbrauch muß ich mal messen.

Sollte ich auf den Netttop wechseln, wäre noch der Wechsel der Festplatte nötig. Dem Laptop hatte ich in diesem Jahr noch eine 1 TB Festplatte spendiert und der Nettop werkelt noch auf der mitgelieferten Mini-Platte mit 250 GB herum. Das ist mir mittlerweile wirklich zu wenig.

Es bleibt also spannend. Und für neue Beiträge wäre ein Umstieg auf den Nettop sicher ein tolles Thema.


Noia Fox 3.1.5 unter Firefox 41.0.1 bis 49.x installieren – funktioniert nicht mehr ab FF50.0 !

17.11.2016

Nachtrag 17.11.16

Wie Reginald L. heute bereits korrekt kommentiert hat, kann man meine einfache Lösung vom 02.10.15 (unten) für die Versionen ab 50.0 nicht mehr verwenden. Schade. Aber es hat immerhin noch über ein Jahr funktioniert.

ff50-0noia3-1-5Der noch recht neue Menüknopf funktioniert beim Firefox 50.0 in Kombination mit Noia Fox 3.1.5 nicht mehr.

Als Alternative empfiehlt Reginald in seinem Kommentar die noiabuttons. Werde ich gleich mal testen.


02.10.15

Wer die alte Version von „Noia Fox“ im neuen Firefox installieren möchte, muß die vorhandene Versionserkennung überlisten und die xpi-Datei der Erweiterung hacken. Dies geschieht natürlich auf eigene Verantwortung. Man sollte zuvor den Firefox und die Nutzerdaten und Profile des Firefox sichern. Es kann sein, dass das addon tatsächlich irgendwann einmal nicht mehr kompatibel ist und der Firefox anschließend nicht mehr nutzbar ist! Das Befolgen der folgenden Anleitung geschieht also ausdrücklich auf eigene Gefahr!

noia

1. Noia Fox 3.1.5 hier herunterladen, indem man mit der rechten Maustaste auf den Knopf „+ Add to Firefox“ klickt und auswählt „Ziel speichern unter“.

2. Die gespeicherte Datei noia_fox-3.1.5-tb+fx.xpi umbenennen in noia_fox-3.1.5-tb+fx.xpi.zip.

3. Öffnen der zip-Datei mit einem Packprogramm wie Engrampa (file-roller sollte auch gehen).

4. Die install.rdf mit einem Text-Editor wie kate öffnen. Also z.B. rechte Maustaste auf die Datei install.rdf und öffnen mit kate. (Ein entpacken der gesamten Datei ist nicht nötig und macht es nur komplizierter.)

5. Im Firefox-Bereich (rechtsbündig in grauer Schrift gekennzeichnet) an der Stelle em:maxVersion die Version eintragen bis zu der die Benutzung erlaubt sein soll. Im Beispiel sind alle Firefox-Versionen bis 41.x erlaubt.

noia_fox-3.1.5-tb+fx.xpi hacken

6. Speichern und schließen der Datei im Texteditor. Anschließend fragt Engrampa ob die zip-Datei aktualisiert werden soll – mit „Ja“ oder „Aktualisieren“ beantworten.

7. Die zip-Datei wieder in eine .xpi umbenennen.

8. Die .xpi vom Dateibrowser wie Dolphin in den Firefox ziehen, um sie zu installieren.

Diese Anleitung habe ich gestestet und sie funktioniert bei mir mit dem Firefox 41.0.1 und Noia Fox 3.1.5 unter Debian 8. Sie lehnt an diese Anleitung an und kommt ohne Gewähr.


Nachtrag 06.10.15

Es ist durchaus möglich, dass meine Anleitung mit entsprechend anderen Tools (z.B. 7zip, Explorer, Notepad) auch unter Windows funktioniert. Wer das bei sich erfolgreich ausprobiert hat, möge doch bitte im Kommentar einen Hinweis hinterlassen auf welchem System es denn geklappt hat bzw. ob und an welcher Stelle es Probleme gab. Das könnte für andere Leser hilfreich sein. (Ich habe festgestellt, dass dieser Artikel ziemlich häufig aufgerufen wurde – deshalb meine Bitte.)


Nachtrag 07.10.15

Danke an Reginald für Deinen Kommentar! Meine Beschreibung funktioniert also auch unter Windows (Version hat er nicht angegeben, aber es wird unter allen Versionen gehen, die den aktuellen Firefox 41.0.1 unterstützen) mit 7zip und Notepad++ (und ganz sicher auch mit Notepad). Freut mich. :-)


Nachtrag 09.10.15

Danke auch an Chris für Deinen Kommentar! Also mit Win7Pro klappt es auch. Super, freut mich. :-)

Tut richtig gut, mal ein paar Antworten zu bekommen. Ich sehe zwar, dass meine Seite – und vor allem die Kalender und auch dieser Artikel hier – ziemlich häufig angeklickt werden, aber ich kann mir nie sicher sein, ob es Spam-Roboter sind oder echte Menschen. Und wenn dann noch positive Rückmeldungen kommen, ist das besonders angenehm. :-)


Nachtrag 04.11.15

Chris meldet in den Kommentaren, dass der Tip auch mit dem ganz neuen Firefox 42 unter Win7Pro funktioniert. – Ich muß gestehen, dass ich das Update noch nicht gemacht habe.

Schön zu wissen. Vielen Dank für die Rückmeldung! :-)


Nachtrag 09.03.16

Meine Anleitung funktioniert auch mit Firefox 45.0, getestet unter Debian 8.


Nachtrag 09.03.16 noia_fox-3.1.5-tb+fx.xpi herunterladen

Problem:

Wer noia_fox-3.1.5-tb+fx.xpi hier herunterladen will und auf „zu Firefox hinzufügen“ klickt, erhält die Fehlermeldung „Firefox hat die Webseite daran gehindert, Sie zu fragen, ob Software auf Ihrem Computer installiert werden soll.“

noia_fox-3.1.5-tb+fx.xpi herunterladen 1

Lösung:

Mit der rechten Maustaste auf „zu Firefox hinzufügen“ klicken

noia_fox-3.1.5-tb+fx.xpi herunterladen 2

und „Ziel speichern unter“ wählen

noia_fox-3.1.5-tb+fx.xpi herunterladen 3


Nachtrag 26.04.16

Meine Anleitung funktioniert auch mit Firefox 46.0, getestet unter Debian 8.


Nachtrag 08.06.16

Meine Anleitung funktioniert auch mit Firefox 47.0, getestet unter Debian 8 32-Bit.


Nachtrag 20.08.16

Meine Anleitung funktioniert auch mit Firefox 48.0.1. Getestet unter Debian 8 32-Bit.


Nachtrag 23.09.16

Meine Anleitung funktioniert auch mit Firefox 49.0. Getestet unter Debian 8 32-Bit.